Dynamics Payment Connector

You can use the Microsoft Dynamics Payment Connector to accept credit and debit card payments from your customers. When you accept a bank card payment, the customer’s payment information is routed through the Payment Connector to bank card networks using Microsoft Dynamics Online Payment Services, via secure servers.

Dynamics Online supports competitive offers from several credit card processors. If you don't have one yet, you can work with your partner to establish a merchant account through Dynamics Online. If you already have a merchant account, you can probably use this same account with your Dynamics Online account and the Payment Connector in Microsoft Dynamics RMS.

To use the Payment Connector, you must complete all of the following steps:

  • Set up your Dynamics Online Payment Services account

  • Configure the integration between Microsoft Dynamics RMS and your Microsoft Dynamics Online account (as described in this topic)

  • Register your public key

  • Set up credit card and debit card payment methods (as described in Store Operations Online Help)

To configure the integration between Microsoft Dynamics RMS and the Payment Connector

1. On the File menu in Store Operations Administrator, click Configuration, and then click the EDC tab.

2. Select the Use electronic draft capture software to verify credit card transactions option.

3. In the EDC software box, select Payment Connector.

4. In the fields provided, use the instructions in the following section to enter information about your Microsoft Dynamics Online Services account.

5. Click OK to save your settings, and then click OK in the Configuration dialog box.

6. Perform a test transaction in Store Operations POS.

Dynamics Payment Connector dialog box

Connectors list: Select Dynamics Payment Connector. You should select TestConnector only if instructed to do so by Microsoft customer support.

Note: If you select TestConnector, the rest of the settings in this dialog box are slightly different from what's provided in this topic. Your support engineer can help you with entering the correct information.

Test mode: Select False. You should select True only if instructed to do so by Microsoft customer support.

Terminal ID: Enter one of the terminal IDs set up for your account. In most cases, each terminal ID should be used only once. Note that the terminal ID in this form is typically not the same as the register number set up in Microsoft Dynamics RMS, although you can use your terminal IDs as your register numbers if you choose.

Assembly name: The value in this box is filled in automatically and cannot be modified.

Merchant account ID: Enter the ID of the merchant account assigned to your account.

Service account ID: Enter the ID of the service account assigned to your account.

Microsoft account: Enter the e-mail address that you use to log on to your Dynamics Online account. Note that the address you enter here may not match the e-mail address where you receive personal or business e-mail messages.

Microsoft account password: Enter the password for the e-mail address in the preceding field. This enables communication between Store Operations and your Dynamics Online account and is not used for any other purpose.

Environment: If it is not already there, type PROD.

Public key: The value in this box is filled in automatically and cannot be changed.

Important: You must associate this public key with your Dynamics Online account. For instructions, see Register your public key.

Portal URL: The portal is the website where you can manage your Dynamics Online account. The value in this box is filled in automatically and cannot be changed. To visit the portal, copy the URL from the box and paste it into the address bar in your browser, then log on to your Dynamics Online account using your Microsoft account and password.

Supported currencies: Select the currency that should be set on each payment that is processed through the connector.

Supported payment methods: Type the card types that you accept in your store, separated by semi-colons (;). Note that the values that you enter here may not match the names of the payment methods that you have set up in Microsoft Dynamics RMS. Only the following values have any effect in this box:

Visa
MasterCard
Amex
Discover
Debit

If you accept all of these in your store, the value in the Supported payment methods box should be:

Visa;MasterCard;Amex;Discover;Debit

If you do not accept all of these, remove it from the list along with the semi-colon that follows it. For example, if you accept all of the card types except Discover, the value in the Supported payment methods box should be:

Visa;MasterCard;Amex;Debit


Set up your Dynamics Online Payment Services account

To set up your account with Microsoft Dynamics Online Payment Services

To set up an account with Microsoft Dynamics Online Payment Services, complete the following steps:

  • Work with your partner to set up a Microsoft Dynamics Online Payment Services account.

Note: To register, you must have a Microsoft account (sometimes referred to as a Windows Live ID). This account is used to authenticate your Dynamics Online account. If you don't have a Microsoft account, you can sign-up for one at http://www.live.com.

  • Choose an offer from several payment providers to establish a merchant account.

  • In Store Operations Administrator, enter your account information and the credentials for your Microsoft account in the Dynamics Payment Connector dialog box. For more information, see Dynamics Payment Connector.

  • Visit the Dynamics Online portal using the URL provided in the Dynamics Payment Connector dialog box and register the public key for the payment connector with your Dynamics Online account. For more information, see Register your public key.


Register your public key

When you first open the Dynamics Payment Connector dialog box in Store Operations Administrator, a unique public key is generated for your store. This public key must be registered with your Microsoft Dynamics Online Payment Services account for payment processing through the Payment Connector to work.

To register your public key

1. In the Dynamics Payment Connector dialog box in Store Operations Administrator, copy the value from the Public key box and paste it into Notepad or another text editor.

2. Copy the value in the Portal URL box, and then paste it into the address bar of your browser.

3. Log on to the portal using your Microsoft account.

4. In the navigation pane on the left side of the screen, under Organization settings, click User management, and then click the System User button to create a new system user.

5. In the web page that opens, click in the Public key box, paste in the public key value that you stored in your text editor in step 1, and then click the Save button.

6. Select the check box for the system user, and then click the Edit button.

7. In the Available Roles box, select Payment Administrators, and then click the right-arrow button to add the role to the Selected Roles box.

Other steps you must complete

Set up your Dynamics Online Payment Services account

Configure the integration between Microsoft Dynamics RMS and the Payment Connector

Set up credit card and debit card tender types (see Store Operations Online Help)